В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
AlsuApuseva
AlsuApuseva
19.08.2021 23:34 •  Информатика

собери схему с подключением 5 светодиодов и напишите программу для бегущих огней согласно следующим алгоритмам​

Показать ответ
Ответ:
staisywell1
staisywell1
16.12.2020 06:21

#include <bits/stdc++.h>

using namespace std;

int search1(string str) {

 for (int i = 0; i < str.size(); i++) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int search2(string str) {

 for (int i = str.size() - 1; i >= 0; i--) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int main() {

 string str = {};

 getline(cin, str);

 int a = search1(str);

 int b = search2(str);

 if (a != -1) {

   if (a == b)

     cout << a;

   else

     cout << a << " " << b;

 }

 return 0;

}

0,0(0 оценок)
Ответ:
tuzor
tuzor
25.05.2023 21:04

program D1;

uses GraphABC;

const c: array[1..3] of integer = (15,20,65);

n: array[1..3] of string = (' Белки ',' Жиры ',' Углеводы ');

var nu,u, i: integer;

begin

SetWindowTitle ('Сбалансированное питание');

SetFontSize(15);

TextOut(185,30,'Сбалансированное питание');

SetFontSize(10);

nu:=0;

for i:=1 to 3 do

begin

case i of

1: SetBrushColor(clred);

2: SetBrushColor(clgreen);

3: SetBrushColor(clblue)

end;

TextOut(285,385+(i*20),n[i]+IntToStr(c[i])+' % ');

u:=nu+trunc(c[i]*360/100);

Pie(320,230,150,nu,u);

nu:=u;

end;

SaveWindow ('Диаграмма питания.bmp')

end.

Объяснение:

картинка

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота