Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
valag84
27.11.2021 18:49 •
Информатика
Составить программу и блок-схему для решения . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. a[n] найти среднее элементов массива а . ai > 0; n=10
Показать ответ
Ответ:
Tigor111
03.10.2020 03:36
#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}
0,0
(0 оценок)
Популярные вопросы: Информатика
мозг2017а
24.04.2020 07:39
1) определи типы переменных a) x: = 23 6) y: = 23.8 b) b: = a r) c: = class д) а: = 20 mod 5 = 0 2) запиши примеры на языке паскаль a) 6) - 4ac 2a+3b 3) вычисли 27 div 4 27...
dina9992
12.08.2022 17:23
Значения x=1; y=0; z=1. найти f = (x& ¬y) v (y & z) v ¬x и построить логическую схему ...
LeaV
15.11.2022 20:16
Составить программу вычеслений степени числа а с натуральным показателем n....
arina270316
05.01.2021 19:16
Запись, a: =d+9 читается так: переменная a равна значению выражения d плюс 9 переменная a приблизительно равна значению выражения d плюс 9 переменной a присвоить значение...
Женёк2006457
14.12.2022 20:16
сделать информатику.Тему вообще не понял...
Lera123yf
22.03.2023 04:36
выполнить задание.Только выполняйте правильно и понятно. Тема:Построение таблиц истинности для логических выражений. Задание.Нужно построить таблицу истинности для логического...
dilayra16
03.05.2023 03:15
Информационный объём флешки,дискеты,оптического диск (CD-ROM),DVD...
zeleninalina20
29.03.2021 06:41
Впиши координаты указанной точки....
Сашаawalon
14.08.2022 11:43
A, b и c – некоторые цифры. Согласно данному выражению найдите abc . A) 14 B) 15 C) 16 D) 17...
анч21
11.02.2022 09:25
Какое значение появится в ячейке С3 при вводе указанных формул?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cmath>
using namespace std;
void main()
{
int n;
float x=1,y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
x *= mass[i];
k++;
}
y = pow(x, 1/k);
cout << " y= " <<y;
system("pause");
}