В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
fghjdgfdjhg
fghjdgfdjhg
19.12.2020 13:33 •  Информатика

Составить программу используя функции по варианту: Найти количество чисел кратных 2 на промежутке от -8 до 11
Язык С++

Показать ответ
Ответ:
Louis12
Louis12
10.10.2022 10:40
По теореме косинусов находим косинус угла, лежащего против большей стороны и определяем вид треугольника.

var a, b, c, alpha: real;
begin
  write('Введите стороны: ');
  read(a, b, c);
  if a < b then swap(a, b);
  if a < c then swap(a, c);
  alpha := (b * b + c * c - a * a) / (2 * b * c);
  if a >= b + c then
    writeln('Треугольник нельзя построить')
  else if alpha = 0 then
    writeln('Треугольник прямоугольный')
  else if alpha > 0 then
    writeln('Треугольник остроугольный')
  else
    writeln('Треугольник тупоугольный')
end.
0,0(0 оценок)
Ответ:
дира3
дира3
15.06.2021 09:25
Pascal
1. var a, b: real;
begin
  write('Введите стороны прямоугольника: ');
  read(a, b);
  writeln('Периметр = ', 2 * a + 2 * b); 
end.

2. var p, b: real;
begin
  write('Введите два числа: ');
  read(p, b);
  writeln('Произведение = ', p * b);
  writeln('Разность = ', p - b);
end.

3. var b: real;
begin
  write('Введите длину ребра: ');
  read(b);
  writeln('Объем = ', b * b * b);
end.

4. var r: real;
begin
  write('Введите радиус: ');
  read(r);
  writeln('Площадь = ', 3.14 * r * r);
end.

5. var a, b, c: real;
begin
  write('Введите три стороны: ');
  read(a, b, c);
  writeln('Периметр = ', a + b + c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота