В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
yanchikkostyas
yanchikkostyas
20.07.2022 08:25 •  Информатика

Составить программу, которая бы запрашивала хнач и хкон и определяла произведение всех положительных чисел от хнач до хкон (решить , используя цикл с предусловием – while .. do). пож

Показать ответ
Ответ:
Юля13002
Юля13002
03.10.2020 18:48
//Pascal WDE

Var
 xk,xn:real;
 i,r,xik,xin:integer;
 b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
 begin
  r:=r*i;
  b:=true;
 end;
inc(i);
end;
if b=true then write(r) else write('0');
end.

Пример ввода:
-2.8
3.8
Пример вывода:
6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота