В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Составить программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и выводит на экран в одну строчку исходный массив, а во вторую строчку все элементы с четными значениями.

Показать ответ
Ответ:
GamerPro3922
GamerPro3922
09.10.2020 12:49

#include <stdlib.h>

#include <time.h>

#include <iostream>

using namespace std;

#define N 16

void main()

{

   int randomNumbers[N];

   srand(time(NULL));

   for (int i = 0;i < N; i++)

   {

       randomNumbers[i] = rand() % 40 - 20;

   }

   for (int i = 0; i < N; i++)

   {

       cout << randomNumbers[i] << "  ";

   }

   cout << endl << endl;

   for (int i = 0; i < N; i++)

   {

       if (randomNumbers[i] % 2 == 0)

       {

       cout << randomNumbers[i] << "  ";

       }

   }

   cout << endl;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота