В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
violettakot01
violettakot01
01.11.2020 20:57 •  Информатика

Составить программу которая считает количество цифр 7 в записи натурального числа.

PASCAL

Показать ответ
Ответ:
Лиза505090
Лиза505090
15.10.2020 00:39

var

 a, count: integer;

begin

 count := 0;

 read(a);

 while a > 0 do

 begin

   if a mod 10 = 7 then

     count := count + 1;

   a := a div 10;

 end;

 writeln(count);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота