Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
tanysha4957
11.03.2022 17:56 •
Информатика
Составить программу которая заполняет массив а случайными целыми числами в диапазоне от 1 до 10 и вычисляет сумму элементов массива с индексом от n до m включительно. числа n и m введите с клавиатуры
Показать ответ
Ответ:
tarlavinEgor
07.10.2020 01:04
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,1,10); a.Println;
var (n,m):=ReadInteger2('Введите n и m:');
Writeln('S=',a[n-1:m].Sum)
end.
Пример
1 8 9 1 2 1 10 4 10 2
Введите n и m: 3 6
S=13
0,0
(0 оценок)
Популярные вопросы: Информатика
madamburkova20
06.04.2022 12:12
1. Линейная структура построения программы подразумевает: a. Неоднократное повторение отдельных частей программы; b. Последовательное выполнение всех элементов программы;...
nikitkaandreev1
08.09.2021 13:04
Решить на Python Дана квадратная вещественная матрица размерности n. Сравнить сумму элементов матрицы на главной и побочной диагоналях....
KIrito5016
20.03.2022 13:39
Определите соответствия...
poliaaaaaa
23.04.2022 12:20
Файл размером 70 мбайт передается через некоторое соединение в течении 40 сек определите скорость передачи данных в мбитах (с объяснениями) 30...
stasleraz
23.07.2022 03:31
Вопросы по информатике: 1. к какому типу программ относятся утилиты? а) прикладные программы обеспечения; б) системное программное обеспечение; в) системы программирования;...
rkarina79
09.09.2022 01:49
Составьте алгоритм ,который вычислит произведение нечетных чисел от - 100 до 50...
lolik334
10.03.2022 09:49
Автоматическая фотокамера каждую секунду создаёт растровое изображение, содержащее 216=65536 цветов. Размер изображения – 640 x 480 пикселей. Все полученные изображения и...
Х1ега1Х
05.10.2022 11:48
Как будет выглядеть фраза Здравствуй, мир! , если набрать её в кодировке UTF-8, а просматривать - в кодировке Windows-1251?...
dumbschoolkid
05.10.2021 20:48
У літньому таборі відпочинку 280 дітей. 2/7 усієї кількості дітей пішли у похід,а 1/8 На екскурсію.СКІЛЬКИ ДІТЕЙ ЗАЛИШИЛОСЯ В ТАБОРІ...
МорскойКот
08.05.2022 10:00
Доказать, используя современный приём ПОПС-формула, что ,,Сказка о царе Берендее... Жуковского В.А. относится к волшебной сказке. Письменно в тетради. именно в ПОПС формуле...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,1,10); a.Println;
var (n,m):=ReadInteger2('Введите n и m:');
Writeln('S=',a[n-1:m].Sum)
end.
Пример
1 8 9 1 2 1 10 4 10 2
Введите n и m: 3 6
S=13