В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ваня1259
ваня1259
13.09.2022 12:27 •  Информатика

Составить программу, которая запрашивает целые числа до тех пор, пока их сумма не превысит 500.
(т.е. после запуска программы пользователя ввести число. Пользователь вводит число, и оно
добавляется к сумме введенных им ранее чисел. Как только это сумма превысит 500 программа должна
закончить свою работу и вывести на экран получившуюся суммы. ПАСКАЛЬ

Показать ответ
Ответ:
аянаайши
аянаайши
21.06.2020 08:01
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
0,0(0 оценок)
Ответ:
Vadosik228
Vadosik228
16.05.2023 01:30

номер 9 Начнем считать количество путей с конца маршрута — с города К. Пусть NX — количество различных путей из города А в город X, N — общее число путей.

 

В К можно приехать из Е, В, Г или Ж, поэтому N = NК = NЕ + NВ + N Г + NЖ (*).

 

Аналогично:

 

NЕ = NБ + NВ = 1 + 1 = 2;

NЖ = NД = 1;

NВ = NА = 1;

NГ = NВ + NА + NД = 1 + 1 + 1 = 3;

NД = NА = 1;

NБ = NА = 1.

 

Подставим найденные значения в формулу (*): N = 2 + 1 + 3 + 1 = 7.

Источник: ГИА по информатике 31.05.2013. Основная волна. Центр, Урал. Вариант 1301.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота