В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Danilkez
Danilkez
31.05.2023 01:20 •  Информатика

Составить программу на языке паскаля: даны числа a,b,c. составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:
равносторонний,равнобедренный или какой либо другой.

Показать ответ
Ответ:
busiginaev2015
busiginaev2015
24.05.2020 13:09

var a,b,c: integer;

begin

  readln(a,b,c);

  if (a>b+c) or (b>a+c) or (c>a+b) then begin writeln('Треугольник не сущесвует'); exit; end;

  if (a=b) or (b=c) or (a=c) then writeln('Равнобедренный треугольник');

  if (a=b) and (b=c) and (a=c) then writeln('Равносторонний треугольник');

  if (sqr(c)=sqr(a)+sqr(b)) or (sqr(b)=sqr(c)+sqr(a)) or (sqr(a)=sqr(b)+sqr(c)) then writeln('Прямоугольный треугольник');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота