В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Оля666Olya
Оля666Olya
27.03.2022 22:53 •  Информатика

Составить программу на языке С++, решающую следующую задачу: Дано трехзначное число.
Найти сумму и произведение его цифр.

Показать ответ
Ответ:
bes10
bes10
28.08.2020 16:35

#include <iostream>

int main()

{

int N, s1 = 0, s2 = 1;

setlocale(LC_ALL, "Russian");  // Русский язык в консоли

std::cin >> N;

while (N > 0)

{

 s1 += N % 10;

 s2 *= N % 10;

 N /= 10;

}

std::cout << "Сумма: " << s1 << std::endl;

std::cout << "Произведение: " << s2;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота