В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
УЧииНИК
УЧииНИК
01.02.2021 04:49 •  Информатика

Составить программу определения кислотности раствора с лакмусовой бумажки. если бумажка окрашивается в красный цвет - раствор кислотный; в синий - раствор щелочной; не меняет цвет - раствор нейтральный.

Показать ответ
Ответ:
одногоВоло
одногоВоло
15.11.2021 23:54
1) Если x^3 < 10, то (x+1)^3 > 20. Это верно при x = 2. 
2^3 < 10, 3^3 > 20
2) Если x(x+1) > 10, то (x+1)(x+2) < 10. Это верно при x = -4
(-4)(-3) = 12 > 10; (-3)(-2) = 6 < 10 
Но при x = 2 будет ложная посылка (2*3 > 10 - это ложно),
из которой следует ложный вывод 3*4 < 10.
Поэтому импликация верна. ответ x = 2
3) Если x(x+1)(x+2) > 25, то x < x-1
Это сложнее. x < x-1 - ложно при любом х.
Импликация будет истинной, только если посылка ложная.
x(x+1)(x+2) > 25 - должно быть ложно. Это при x = 2.
x(x+1)(x+2) = 2*3*4 = 24.
0,0(0 оценок)
Ответ:
1234234421
1234234421
21.04.2020 20:37
//PascalABC.Net 3.0, сборка 1064
const
  n=20;
var
  a:array[1..n] of integer;
  i,imax,imin:integer;
  s:longint;
begin
  Randomize;
  Writeln('Исходный ряд значений');
  imax:=1; imin:=1;
  for i:=1 to n do begin
    a[i]:=Random(51)-25; Write(a[i],' ');
    if a[i]>a[imax] then imax:=i
    else
      if a[i]<a[imin] then imin:=i
  end;
  Writeln;
  if imax>imin then
    Writeln('Максимальный элемент встретился позже минимального')
  else begin
    s:=0;
    for i:=imax+1 to imin-1 do s:=s+a[i];
    Writeln('Сумма элементов между максимальным и минимальным значением ',s)
  end
end.
 
Тестовое решение:
Исходный ряд значений
10 -3 9 5 20 10 6 2 -19 -19 6 -24 -7 -1 23 11 -8 -16 -14 -25
Сумма элементов между максимальным и минимальным значением -27
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота