Составить программу перевода информационной ленты из начального состояния в конечное. положение каретки выделено. работу машины представить в виде таблицы. (машина поста) 1111 1 110101 - дано 000000010 1 0 - должно получится положение каретки выделено пробелами
var
v:array[1..100] of integer;
i,j,n,b:integer;
begin
randomize;
write('vvedite razmernost'' massiva: '); readln(n);
writeln(' Ishodnii massiv '); writeln;
//Заполним массив случайными числами
for i := 1 to n do
begin
v[ i]:=random(100)-50;
write(v[ i]:4);
end;
writeln;
// организуем сортироваку от минимального
// к максимальному элементу массива
for i:=1 to n-1 do
for j:=i+1 to n do
if v[ i]>v[ j] then
begin
b:=v[ i];
v[ i]:=v[ j];
v[ j]:=b;
end;
writeln;
write(' Otsortirovannii massiv ');writeln;writeln;
write('ot min k max: ');writeln;
for i := 1 to n do
write(v[ i]:4); writeln; writeln;
write('ot max k min: '); writeln;
for i := n downto 1 do
write(v[ i]:4);
readln;
end.
t = 2pi*sqrt(l/g)
в среде это g будет, естественно, меньше, так как на шарик действует выталкивающая сила.
найдём это g.
по 2 закону ньютона f = p-fa = pш*v*g0 - рс*v*g0=v*g0*(pш-рс)=m*g = pш*v*g
откуда g = g0*(1-pc/pш)
я использовал обозначения
g0 - стандартное ускорение свободного падения
рш - плотность шарика
рс - плотность среды
v - объём шарика.
то, что я написал, это просто закон архимеда, не более того. а закон ньютона - как скобки.
подставим в исходную формулу, получим
t = 2pi*sqrt(l/g0*(1-pc/pш))
подставим исходные данные
t = 2*pi*sqrt(0.1/g0*(1-1/1.2)) =2*pi*sqrt(6/(10*g0))=2*pi*sqrt(3/(5*g0)) = 2*3.14159*sqrt(3/(5*9.81)) = 1.556c = 1.56c
замечание1. в приближённых вычислениях часто принимают во внимание тот факт, что g = pi^2 c хорошей точностью. это значительно вычисления.
в нашем случае сразу получаем
t = 2*pi*sqrt(l/(g0*(1-1/1. = 2*sqrt(0.1*1.2/0.2) = 2*sqrt(0.6)=1.55 = 1.55c
то есть совпадение до сотых! а вычислять проще.
замечание2 это соотношение действительно только в системе си и его не сложно "доказать". нужно только вспомнить, что такое метр, когда его вводили при наполеоне.
вот вроде и всё.
хотя нет. попробуй исследовать полученную формулу. а что если плотность среды выше плотности шарика?
(подсказка - маятник перевернётся "вверх ногами").
ну и последнее. при таких плотностях среды(сравнимых с плотностью шарика) пренебрегать сопротивлением среды - рискованно, это сопротивление, как правило, большое и существенно влияет на поведение маятника.