В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
plz11POMOGITE11plz
plz11POMOGITE11plz
07.01.2020 10:16 •  Информатика

Составить программу расчета значения функции
Z = (х – 2 ctg 2у )/| 8х – 5 arctg у| при любых значениях х и у. Результат вывести в виде: при х= ... и у=... z=...

Показать ответ
Ответ:
ylau2006g
ylau2006g
05.04.2020 08:03

ответ:

. в нужно вывести все составные числа из промежутка [2; n]. код программы:

program lab3;

var i,n,j,s,l: integer;

m: real;

begin

readln (n);

for i: =2 to n do

begin

s: =trunc (sqrt (i));

for l: =2 to s do

begin

m: = i mod l;

if m=0 then

write (' ',i);

end;

end;

end.

но проблема - как только s становится больше 2, составные числа начинают несколько раз повторятся, т.к., например 12 делится и на 2 и на 3. вопрос: как мне сделать выход из цикла после первого успешного деления?

var

i, n, j, s, l: integer;

m: real;

begin

readln(n);

for i : = 2 to n do

begin

s : = trunc(sqrt(i));

for l : = 2 to s do

begin

m : = i mod l;

if m = 0 then

begin

write(' ', i);

break;

0,0(0 оценок)
Ответ:
Bandit009
Bandit009
11.05.2020 18:49
Информационный вес символа при алфавитном подходе считается, что каждый символ текста имеет определенный информационный вес, информа­ционный вес символа зависит от мощности алфавита. а ка­ким может быть наименьшее число символов в алфавите? оно равно двум! скоро вы узнаете, что такой алфавит ис­пользуется в компьютере. он содержит всего 2 символа, ко­торые обозначаются цифрами «0» и «1». его называют дво­ичным алфавитом. изучая устройство и работу компьютера, вы узнаете, как с всего двух символов можно пред­ставить любую информацию. информационный вес символа двоичного алфавита принят за единицу информации и называется 1 бит.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота