В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
rsharapov
rsharapov
28.08.2022 13:48 •  Информатика

Составить программу. В целочисленной последовательности есть нулевые элементы. Вывести номера этих элементов.

Показать ответ
Ответ:
Sayva11
Sayva11
12.02.2021 19:38

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE, "Russian");

int n;

cout << "Введите размер массива - ";

cin >> n;

int* a = new int[n];

cout << "Массив: ";

for (int i = 0; i < n; i++)

{

cin >> a[i];

}

cout << "Индексы нулевых элементов: ";

for (int i = 0; i < n; i++)

{

if (a[i] == 0)

{

cout << i<< " ";

}

}

delete []a;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота