Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
annakolupaewa20
19.04.2021 18:51 •
Информатика
Составить программу в pascal, найти сумму произведений 1 и 2, 3 и 4, и тд элементов массива состоящего из 10 значений. заранее !
Показать ответ
Ответ:
daria200205
07.10.2020 18:04
Var
a:array[1..10] of integer;
i, ans:integer;
begin
Writeln('Введите массив из 10ти элементов: ');
for i:= 1 to 10 do
read(a[i]);
i:= 1; ans:= 0;
while i < 10 do
begin
ans:= ans + a[i] * a[i+1];
i:= i + 2;
end;
Writeln(ans);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
vitoszemko200
05.09.2020 14:34
решить информатику, заранее...
Русель
14.04.2023 01:43
Задача 1. Информационный объем сообщения 1,5 Мбайта, содержит 3145728 символа. Сколько битов приходится на 1 символ. Задача 2. Объем сообщения составляет 1/512 часть...
egorkarevyakin
21.05.2023 00:45
Пусть x=-3 какие действия произведет оператор:...if x =5 then x:=2*x...
sashapustoxin
05.07.2022 14:15
Втаблице запросы и количество страниц, которые нашел поисковый сервер по этим запросам в некотором сегменте интернета: запрос количество страниц яблоки & груши...
nmedvedeva20018
21.09.2022 18:37
Генерация случайной буквы на python...
nat17akan
02.05.2021 10:05
1.даны два целых числа a и b (a b ). найти сумму всех чисел от a до b включительно. 2. даны два целых числа a и b (a b, a 0). найти произведение всех чисел от a до...
Grisha222
02.05.2021 10:05
Написать программу на паскаль ввести с клавиатуры название фигуры, которую надо построить: круг или треугольник. нарисовать соответствующую фигуру синего цвета на...
Feruz2004
02.05.2021 10:05
Написать программу, которая задает пользователю вопрос о том, какую фигуру тот выбирает: прямоугольник, или треугольник. после того, как пользователь выберет фигуру,...
omim
17.06.2022 08:15
В чём преимущества представления алгоритмов в виде блок-схем и какой недостаток этого представления ?...
Dashaegor540
05.10.2020 03:38
Определите результат выполнения программы при входных данных 7 3 15 a=int(input())b=int(input())c=int(input())min=a;if b min:min=bif c min:min=c не пишите Определите...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a:array[1..10] of integer;
i, ans:integer;
begin
Writeln('Введите массив из 10ти элементов: ');
for i:= 1 to 10 do
read(a[i]);
i:= 1; ans:= 0;
while i < 10 do
begin
ans:= ans + a[i] * a[i+1];
i:= i + 2;
end;
Writeln(ans);
end.