В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
lover7
lover7
16.12.2022 05:48 •  Информатика

Составить программу (в pascal) позволяющую найти минимальный элемент массива. подсчитать количество элементов в массиве, равных минимальному. размеренность массива произвольная.

Показать ответ
Ответ:
phon1
phon1
26.06.2020 11:00
Program my;
var  k,i,z:integer; 
     a:array[1...N]:integer; 
begin
k:=99999;
for i:=1 to N do                   
 if a[i]<k then k:=a[i];
z:=0;
for i:=1 to N do 
 if a[i]=k then z:=z+1;
end.
=)  
0,0(0 оценок)
Ответ:
Kybe009
Kybe009
26.06.2020 11:00
Uses crt;
const N=10;
var a:array [1..N] of integer;
     x,min,k:integer;
begin
for x:=1 to N do
begin
write('a[',x,']:',a[x]);
readln(a[x]);
end;
min:=a[1];
for x:=1 to N do
if a[x]<min then min:=a[x];
for x:=1 to N do
if a[x]=min then inc(k);
writeln('Минимальный элемент: ',min,'. Таких элементов в массиве: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота