Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел от 1 до n. В каждой строке надо напечатать очередное число и столько символов “+”, сколько делителей у этого числа. Например, если n = 4, то на экране должно быть напечатано:
1+
2++
3++
4+++
Код на Pascal выводит точно то, что требуешь )). Напомню лишь, не забудь про отступы, когда будешь писать/копировать код. Удачи! )):
var i,j,m,n: integer;
pl{,i_s}: string;
begin
pl:= '';
writeln('Enter n: n = ');
readln(n);
for i:= 1 to n do
begin
for j:= 1 to i do
begin
pl:= pl + '+';
end;
//i_s:= string(i);
writeln(i{_s},' ',pl);
pl:= '';
end;
end.