В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
nurbibisaidova3
nurbibisaidova3
04.09.2020 19:38 •  Информатика

Составить программу в паскале.даны три положительных числа а,в,с. проверить, могут ли быть они длинами сторон треугольник. если да, то вычислить площадь треугольника. (нужно учитывать, что стороны не могут равняться нулю. и возможно существование равностороннего треугольника) основные формулы: а< =б+с, б

Показать ответ
Ответ:
pnasta434
pnasta434
12.06.2020 06:31

var a,b,c,p:integer;
begin
  writeln('введите a');
   readln(a);
  writeln('введите b');
   readln(b);
  writeln('введите c');
   readln(c);
  if (a<=b+c) and (b<a+c) and (c<=a+b) then
    begin
       p:=(a+b+c) div 2;
       writeln('Треугольник может существовать');
       writeln('Площадь: ', sqrt(p* ((p-a)*(p-b))*((p-c))):1:2);  //Формула герона
    end
  else writeln('Не треугольник');
  readln();
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота