В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
patimatgemmamailru
patimatgemmamailru
16.05.2021 02:09 •  Информатика

Составить программу вычисления суммы чётных чисел и произведение нечётных чисел от 1 до 10. (через паскаль)

Показать ответ
Ответ:
SashaRary
SashaRary
24.05.2020 23:10

Паскаль.

 

 

program jjj;

var a: array [1..10] of integer; i,summa,proizv:integer;

begin

for i:=1 to 10 do begin

   Writeln('напишите элемент массива номер ',i); read(a[i]);

                        end;

For i:=1 to 10 do begin

                              if a[i] mod 2=0 then summa:=summa+a[i] else

                                if (a[i]<=10) and (a[i]>=1) then  proizv:=proizv*a[i];

                         end;

Writeln(summa,'   ',proizv); readln;

end.

 

Жирным - это то, что я добавил)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота