В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
emeli2007
emeli2007
03.01.2020 19:19 •  Информатика

Составьте программу для расчёта b=(17+28t)/(1-27t), t – любое целое число(Подсказка при описание переменной t подумайте она real или integer).

Показать ответ
Ответ:
kjhf2225
kjhf2225
25.03.2023 01:31
Const
  n=7;

type
  V=array[1..n] of real;

var
  P:V;
  i,k:integer;
  a,b,c,d:real;

begin
  Writeln('Вводите длины сторон четырехугольника через пробел');
  for i:=1 to n do begin
    Write(i,': '); Read(a,b,c,d);
    P[i]:=a+b+c+d;
    end;
  k:=0;
  for i:=n-1 downto 1 do
    if P[i]=P[n] then k:=k+1;
  Writeln('Четырехугольников с периметром, как у последнего: ',k)
end.

Пример
Вводите длины сторон четырехугольника через пробел
1: 5 7 3 8
2: 3 7 3 6
3: 5 8 5 2
4: 6 8 4 1.9
5: 8 3 5 9
6: 7 3 7 2
7: 5 5 5 4
Четырехугольников с периметром, как у последнего: 2
0,0(0 оценок)
Ответ:
кака231
кака231
02.08.2022 19:03
//PascalABC.NET
//Версия 3.3, сборка 1611 (06.01.2018)

begin
  var a:=MatrRandom(4,5,-20,20).Println;
  var c:=a.ElementsByRow;
  Println('Кол-во положительных ->',c.Where(t->t>0).Count);
  Println('Кол-во кратных 7 ->',c.Where(t->t mod 7=0).Count);
  Println('Сред. арифм. отрицат. ->',c.Where(t->t<0).Average);
  var b:=a.ElementsWithIndexes.MinBy(t->t[0]);
  Writeln('Минимальный ->', b[0],'[',b[1]+1,',',b[2]+1,']');
  b:=a.ElementsWithIndexes.Where(t->t[0]<0).MaxBy(t->t[0]);
  Writeln('Максимальный отриц. ->', b[0],'[',b[1]+1,',',b[2]+1,']');
end.

Пример:
 -10   6  12   7   4
  -8  -4   3  -1   6
   9  -2  16  19 -18
  18   4  -3  12  -8
Кол-во положительных -> 12 
Кол-во кратных 7 -> 1 
Сред. арифм. отрицат. -> -6.75 
Минимальный ->-18[3,5]
Максимальный отриц. ->-1[2,4]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота