В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
DanilVOLK228
DanilVOLK228
25.07.2020 05:22 •  Информатика

Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В. С (где число В равно 19, число А на 1 меньше числа В и число С на 1 больше числа В). Если их сумма четное число, то найдите и выведите на экран их произведение. Иначе, выведите на экран квадраты этих чисел в порядке возрастания. Выполнить в PascalABC.

Показать ответ
Ответ:
Kostya2347
Kostya2347
05.07.2021 17:50

var

 a,b,c:integer;

begin

readln(a,b,c);

if (a+b+c)mod 2 = 0 then

 writeln(a*b*c)

   else

    writeln(sqr(a),' ',sqr(b),' ',sqr(c));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота