В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
lusine20041904
lusine20041904
24.02.2021 08:57 •  Информатика

Составьте программу, которая имитирует движение мяча(круг) слева направо.

Показать ответ
Ответ:
брат2006кирилл
брат2006кирилл
22.05.2020 21:51

Відповідь:

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

const int size = 20;

void randarr(int *arr,const int size){

for(int i = 0; i < size; i++){

 arr[i] = rand() % 30 + 1;

}

}

void printarr(int *arr,const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int maxarr(int *arr,const int size){

int max = arr[0];

for(int i = 0; i < size; i++){

 if(arr[i] > max){

  max = arr[i];

 }

}

return max;

}

void findsix(int *arr,const int size){

int six,counter = 1;

for(int i = 0; i < size; i++){

 if(arr[i] == 6){

  six = arr[i];

  break;

 }

 counter++;

}

if(six == 6){

 cout << "\nЧисло 6 найдено под номером " << counter << endl;

}

else{

 cout << "\nЧисло 6 не найдено..." << endl;

}

}

int unique(int *arr,const int size){

int t,uniq = 0;

for(int i = 0; i < size; i++){

    t=0;

 for(int j = 0; j < size; j++)

     if (arr[i] == arr[j])

      t++;

 if(t==1)

 uniq++;

}

return uniq;

}

int main(){

srand(time(NULL));

setlocale(LC_ALL , "Rus");

int arr[size];

randarr(arr,size);

printarr(arr,size);

cout << "\nМаксимальный елемент = " << maxarr(arr,size);

findsix(arr,size);

cout << "\nКол-во уникальных елементов = " << unique(arr,size);

return 0;

}

0,0(0 оценок)
Ответ:
olia108
olia108
04.07.2021 01:15

1) 2

в одном мегабайте 1024 килобайт - > 1/512 * 1024 = 1024 / 512 = 2

2)625

5*5*5*5 = 625 - четыре позиции и пять букв

3)10

2^i = 32 => i = 5 -> 128 *128*5 = 81 920 бит = 10 Кбайт

4) 4

195 в двоичной = 1100 0011 -> ответ 4 единицы

5)51

запишем решение на python:

a = '123'

a = int(a, 6)

print(a)

6) 256

так как у нас кодовое слово 1 байт = 8 бит -> i = 8 -> 2^8 = 256 символов

7) 400

Считаем кол-во символов в строке = 50 -> наше сообщение 50 байт = 400 бит

8)123

получаем следующее уравнение ->

2*64000*32*x = 60*1024*1024* 8

x = 60*1024*1024* 8 /2*64000*32

x = 122,88 минут

округляем до 123 минут

9)56

Напишем программу на python для решения задачи:

a = int('AB', 16)

b = int('344', 8)

counter = 0

for i in range(a+1, b):

   counter += 1

print(counter)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота