В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dasha2468135
dasha2468135
16.04.2021 23:04 •  Информатика

Составьте программу,которая нарисует квадрат со стороной a и окружность,вписанную в квадрат

Показать ответ
Ответ:
Cerega67
Cerega67
11.06.2020 22:52

uses graphabc;
var a: integer;
begin
write('Введите сторону квадрата: ');
read(a);
clearwindow;
rectangle(50,50,50+2*a,50+2*a);
circle(50+a,50+a,a);
end.

Программа должна работать, но есть одно "но": она рисует квадрат со стороной 2а вместо а. Такие дела :) Надеюсь, что не критично.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота