В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Vyacheslav009
Vyacheslav009
08.12.2020 07:17 •  Информатика

Составьте программу которая найдет три последние цифры произведения 1*2**18

Показать ответ
Ответ:
Программу можно и не составлять (среди сомножителей есть 2, 5, 10, 12, 15 и, следовательно произведение будет оканчиваться на 3 нуля).
Если нужно найти не 3, а 4 последние цифры, то программа может быть такой:
var i,p:integer;
begin
p:=1;
for i:=1 to 18 do p:=p*i mod 10000;
writeln(p);
end.

Результат:
8000

А если вместо mod 10000 написать mod 1000, то:
Результат:
0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота