В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
fatyaa22
fatyaa22
04.03.2022 10:47 •  Информатика

Составьте программу, которая печатает в первой строке знак &, во второй – повтор через два пробела '& &', в третьей - '& & &', ..., в строке с номером 9 - 9 pаз & через пробел. Печать строки оформить через процедуру. Число строк вводить с клавиатуры. Текст Вашей программы сохранить в файл PascalABC.net. Прикрепить файл программы к этому заданию. После begin основной программы написать что делает эта программа writeln('Программа печает(выводит на экран)...(заполнить) ');

Показать ответ
Ответ:
Валерияжеле
Валерияжеле
24.12.2022 09:59
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

procedure CreateFile(p:string);
begin
  var f:=OpenWrite(p);
  Writeln(f,'В чащах юга жил бы цитрус? Да, но фальшивый экземпляръ!');
  Writeln(f,'СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ');
  Writeln(f,'ФлегмаТичНая этА веРБлЮдиЦа жует у пОДЪезда засыХающий горький шиповник');
  Writeln(f,'The quick brown fox jumps over the lazy dog');
  Writeln(f,'THE FIVE BOXING WIZARDS JUMP QUICKLY');
  f.Close
end;

procedure UpFile(p:string);
begin
  var a:=ReadAllLines(p);
  WriteAllLines(p,a.Select(s->UpperCase(s)).ToArray);
end;

begin
  var p:=ReadlnString('Введите имя файла (можно, с путём):');
  CreateFile(p);
  UpFile(p);
  // контроль работы
  ReadAllLines(p).Println(NewLine)
end.

Пример работы
Введите имя файла (можно, с путём): MyTest.txt
В ЧАЩАХ ЮГА ЖИЛ БЫ ЦИТРУС? ДА, НО ФАЛЬШИВЫЙ ЭКЗЕМПЛЯРЪ!
СЪЕШЬ ЖЕ ЕЩЁ ЭТИХ МЯГКИХ ФРАНЦУЗСКИХ БУЛОК, ДА ВЫПЕЙ ЧАЮ
ФЛЕГМАТИЧНАЯ ЭТА ВЕРБЛЮДИЦА ЖУЕТ У ПОДЪЕЗДА ЗАСЫХАЮЩИЙ ГОРЬКИЙ ШИПОВНИК
THE QUICK BROWN FOX JUMPS OVER THE LAZY DOG
THE FIVE BOXING WIZARDS JUMP QUICKLY
0,0(0 оценок)
Ответ:
emilgasanov
emilgasanov
15.08.2020 03:54
//C# first problem
using System;
class Programm
{
  static void Main()
  {
     int n=int.Parse(Console.ReadLine());
     int[] a=new int [n];
     for (int i=0;i<n;i++)
     {
        a[i]=i;
        Console.Write(a[i] + " ");
     }
  }
}

//C# second problem
using System;
class Programm
{
  static void Main()
  {
     int n=int.Parse(Console.ReadLine());
     int[] a=new int [n];
     int ma=0,mi=0,ma_p=0,mi_p=0;
     for (int i=0;i<n;i++)
     {
        a[i]=int.Parse(Console.ReadLine);
     }
     ma=a[0];mi=a[0];ma_p=0;mi_p=0;
     for (int i=0;i<n;i++)
     {
        if (ma<a[i]){ma=a[i];ma_p=i;}
        if (mi>a[i]){mi=a[i];mi_p=i;}
     }
     ma=a[ma_p];
     a[ma_p]=a[mi_p];
     a[mi_p]=ma;
     for (int i=0;i<n;i++){Console.Write(a[i] + " ");}
  }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота