Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016 begin var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10); var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0); Write('Отрицательных- ',t.Count,'; их номера '); t.Select(x->x[1]).Println end.
Пример Введите 10 чисел, нажмите Enter 3 14 0 -13 6 -11 -4 0 7 12 Отрицательных- 3; их номера 4 6 7
begin
var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
Write('Отрицательных- ',t.Count,'; их номера ');
t.Select(x->x[1]).Println
end.
Пример
Введите 10 чисел, нажмите Enter
3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7