В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Составьте программу, которая при выборе соответствующей командной кнопки, изменяет:
1. Содержание надписи на «Язык программирования», «Система программирования», «Алгоритм»; дополнительно выводится сообщение
за работу»при завершении работы программы.
2. Цвет формы на голубой, фиолетовый, серый; дополнительно выводится
сообщение при запуске программы об условии задачи.
3. Вид отображения рамки панели «выпуклая», «вдавленная», «отсутствует»; дополнительно выводится сообщение о назначении компонентов при
щелчке мыши на данной компоненте. Программка в Паскале.

Показать ответ
Ответ:
Лена200115
Лена200115
29.01.2022 12:09
Алгоритм
1) a x a = a² ⇒ b;    b x a = a³ ⇒ результат
2) a x a = a² ⇒ b;    b x b = a⁴ ⇒ c;   c x c = a⁸ ⇒ c;   c x b = a¹⁰ ⇒ результат

Программа на языке PascalABC.Net
var
  a,b,c,y:real;
begin
  Write('Введите число: '); Read(a);
  b:=a*a; y:=b*a; Writeln('Третья степень числа равна ',y);
  c:=b*b; c:=c*c; y:=b*c;
  Writeln('Десятая степень числа равна ',y)
end.

Тестовые решения:
Введите число: 2
Третья степень числа равна 8
Десятая степень числа равна 1024

Введите число: -13.594
Третья степень числа равна -2512.128188584
Десятая степень числа равна 215512594781.574
0,0(0 оценок)
Ответ:
seryogasaprikin
seryogasaprikin
13.07.2022 10:57
Var a:array of array of integer;
c:array of array of integer;
ma:array of array of integer;
i,j,n:integer;
begin;
randomize;
readln(n);
setlength(a,n+1); //задаём размерность динамических массивов
setlength(c,n+1);
setlength(ma,n+1);
for i:=1 to n do
begin;
setlength(a[i],n+1);
setlength(c[i],n+1);
setlength(ma[i],n+1);
end;

writeln('Matrix A:');   //генерируем массив псеводслучайных чисел
for i:=1 to n do begin;
 writeln;
  for j:=1 to n do
   begin;
    a[i,j]:=random(10);
    write(a[i,j]:4);
   end;
 end;
writeln;

writeln('Matrix C:'); //аналогично
for i:=1 to n do
 begin;
 writeln;
  for j:=1 to n do
   begin;
    c[i,j]:=random(10);
    write(c[i,j]:4);
   end;
 end;

for i:=1 to n do     //сохраняем матрицу C для транспонации
  for j:=1 to n do
    ma[i,j]:=c[i,j];
    writeln;

writeln('Transpose matrix C:'); //транспонируем C
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     c[i,j]:=ma[j,i];
     write(c[i,j]:4);
    end;
 end;

writeln;
writeln('Final matrix:'); // получаем финальную матрицу
for i:=1 to n do
 begin;
  writeln;
   for j:=1 to n do
    begin;
     ma[i,j]:=2*c[i,j]*a[i,j];
{по свойству дистрибутивности матриц С(A+A)=C*A+C*A=2*C*A}
     write(ma[i,j]:4);
    end;
 end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота