В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Kunizhevajenya
Kunizhevajenya
22.09.2022 04:05 •  Информатика

Составьте программу, которая запрашивает значение вещественного числа x и выводит на экран сумму и разность x и 100. ( Pascal ) Протокол программы:
x = 15.2
15.2 + 100 = 115.2
15.2 - 100 = - 84.8 ​

Показать ответ
Ответ:
alyaagafonova
alyaagafonova
10.02.2020 16:13
Алгоритм:
Объявляем 4 переменные вещественного типа и считываем их.
Выводим математическую формулу, для вычисления стоимости.
Количество бензина на 1 км пути * удвоенное расстояние до дачи * цена бензина.

Ниже приведена программа на языке Паскаль

var
S, count, price, ans:real;
Begin
Writeln('Введите расстояние до дачи -> ');Readln(s);
Writeln('Введите расход бензина на 100 км пути -> ');Readln(count);
Writeln('Введите цену бензина -> ');Readln(price);
ans:= ((count/100)* 2*s * price );
Writeln('Стоимость поездки: ', ans);
end.

Пример:
Введите расстояние до дачи ->
28.54
Введите расход бензина на 100 км пути ->
13.1
Введите цену бензина ->
45
Стоимость поездки: 336.4866
0,0(0 оценок)
Ответ:
jokertop666
jokertop666
26.05.2022 10:56
// PascalABC.NET 3.3

const n=7;
begin
  Writeln('Исходный массив:');
  var a:=MatrRandomReal(n,n,-5,5); a.Println(6);
  var m:=a.ElementsByRow.Min;
  var imin:=a.ElementsWithIndexes.Where(k->k[0]=m).Select(k->k[1]).Single;
  var jmin:=a.ElementsWithIndexes.Where(k->k[0]=m).Select(k->k[2]).Single;
  writeln('min = a[',imin+1,',',jmin+1,'] =',m:6:2);
end.

Пример:
Исходный массив:
  4.68 -4.11  2.18  2.34 -1.06 -0.69  1.67
  4.58  3.27  1.39  4.55  0.32  0.65 -3.59
  3.10  0.66  0.94 -4.27 -1.46 -3.82 -0.40
 -4.90 -2.71  2.46 -1.43 -1.62  0.45  1.78
  1.59 -1.07  1.60 -0.16 -1.57 -0.83  2.95
  4.19 -3.16 -4.25  1.71 -4.27  1.04 -3.72
 -4.16 -2.30  0.90  4.46  3.51 -4.66  2.87
min = a[4,1] = -4.90
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота