В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
арсен187
арсен187
25.01.2021 07:02 •  Информатика

СОСТАВЬТЕ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ Составить программу. Коммерсант, имея стартовый капитал k рублей, занялся торговлей, которая ежемесячно увеличивает капитал на p%. Через сколько лет он накопит сумму s, достаточную для покупки собственного магазина?

Показать ответ
Ответ:
Мальчик123870
Мальчик123870
04.09.2020 14:55

var

 n,s,p:integer;

 l,k:real;

 

begin

 readln(k);

 readln(p);

 readln(s);

 n:=0;

 repeat

  l:=k*p/100;

  k:=l+k;

  n:=n+1;

 until k > s;

 write(n div 12,'Лет',n mod 12,'Месяцов');

 readln;

end.

взял отсюда: https://studassistent.ru/turbo-pascal/kommersant-imeya-startovyy-kapital-turbo-pascal

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота