В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sbengardt
sbengardt
27.10.2021 04:24 •  Информатика

Составьте программу определения наименьшего общего кратного 2 натуральных чисел. на абс паскале

Показать ответ
Ответ:
fsb001
fsb001
31.07.2020 21:56
Program Project2;

{$APPTYPE CONSOLE}

uses
SysUtils;

var
n,m,k,c:integer;

function NOD(x,y:integer):integer;
Begin
If x<>0 then NOD:=NOD(y mod x,x) else NOD:=y;
End;

function NOK(x,y:integer):integer;
Begin
NOK:=(x div NOD (x,y))*y;
end;

begin
writeln('Enter M, N, K');
write('m = ');readln(m);
write('n = ');readln(n);
write('k = ');readln(n);
c:=NOK(k,m);
k:=nok(c,n);
writeln('NOK(M,N,K) = ',k);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота