В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
rhenfzj
rhenfzj
09.02.2023 08:17 •  Информатика

Составьте программу, по которой на экран будет выведена вся таблица умножения

Показать ответ
Ответ:
даниля3
даниля3
21.07.2020 12:20
Var b,a:integer; 
begin
 for b:=1 to 10 do begin
  for a:=1 to 10 do begin
   writeln(a,'*',b,'=',a*b);
  end;
 end;
end.
получается не в виде таблицы
 а в столбик
0,0(0 оценок)
Ответ:
CasDavis
CasDavis
21.07.2020 12:20
// F#
[<EntryPoint>]
let main argv =
    let generateTable n m =
        Array2D.init n m (fun i j -> (i+1) * (j+1))
    let printMatrix (matrix:int[,]) =
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf "%4d " (i+1)
        printf "\n"
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf ""
        printf "\n"
        for j = 0 to (Array2D.length2 matrix) - 1 do
            printf "%2d |" (j+1)
            for i = 0 to (Array2D.length1 matrix) - 1 do
                printf "%4d " matrix.[i, j]
            printf "\n"
        printf "\n"
    let inputArray = generateTable 10 10
    printMatrix inputArray
    System.Console.ReadKey true |> ignore
    0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота