В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
7rus790
7rus790
05.02.2022 00:34 •  Информатика

Составьте программу, вычеркивающую из слова х буквы, встречающиеся при написании слова х ровно три раза. (паскаль)

Показать ответ
Ответ:
ibrunetochka
ibrunetochka
06.10.2020 00:05
Var s:string; c:char; i,j,k:integer;
begin
write('Слово: ');
readln(s);
writeln(s);
i:=1;
while i<length(s)-1 do
 begin
 k:=0; c:=s[i];
 for j:=1 to length(s) do
  if c=s[j] then k:=k+1;
 if k=3 then 
  begin
  while pos(c,s)>0 do delete(s,pos(c,s),1);
  i:=i-1;
  end;
 i:=i+1;
 end;
writeln(s);
end.

Пример:
Слово: pnbouipobnpongnf
pnbouipobnpongnf
nbuibnngnf
0,0(0 оценок)
Ответ:
makarovanasta201
makarovanasta201
06.10.2020 00:05
// Паскаль
// Программа поддерживает латиницу, кириллицу и дефисы

const
  // Первая буквы, англ. "a" - 65, но может быть дефис #45
  first_letter = #45;
  // Последняя буквы, рус. "я"
  last_letter = #1103;

var
  x: string;
  i: integer;
  c: char;
  // Сколько раз встречает буква в слове
  count: array[first_letter..last_letter] of integer;
begin
  readln(x);
  // Обнуляем массив
  for c := first_letter to last_letter do
    count[c] := 0;
  // Подсчитываем буквы в слове
  for i := 1 to length(x) do
    inc(count[x[i]]);
  // Выводим слово без букв, встречающихся 3 раза
  for i := 1 to length(x) do
    if count[x[i]] <> 3 then
      write(x[i])
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота