В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
durindub007
durindub007
25.02.2021 03:54 •  Информатика

Составьте программу вычисления произведения элементов матрицы b(n,n),кратных 3. турбо паскаль

Показать ответ
Ответ:
KOBPAHET
KOBPAHET
01.10.2020 06:55

Program JolieWErnAje;
uses crt;
const n=10;
var
  a:array[1..n,1..n] of integer;
  i,j: integer;
  tp: integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  tp:=1;
  randomize;
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          a[i,j]:= random(20)+1; {заполняем массив}
          write(a[i,j]:4);
          if a[i,j] mod 3 = 0 then tp:=tp*a[i,j];
        end;
      writeln();
    end;
  writeln();
  writeln('Произведение элементов, кратных 3, равно ',tp)
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота