В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ElliDiHastua
ElliDiHastua
28.05.2023 04:58 •  Информатика

Составьте программу, выводящую на экран все трехзначные восьмиричные числа которые начинаются и заканчиваются на одну и ту же цифру Обязательно цикл while. ​

Показать ответ
Ответ:
fox590
fox590
06.05.2022 07:34

3

Объяснение:

В а[0] - минимальное значение в массиве.

Если а[i] меньше а[0] то делаем вот что:

1) увеличиваем с на один

2) меняем местами а[0] и а[i].

Т.е. с увеличением каждый раз, когда видим что а[0] больше а[i]

Массив такой:6, 7, 3, 8, 5, 1, 2, 0, 9, 4

Первый раз это случится с тройкой и массив станет таким:

3, 7, 6, 8, 5, 1, 2, 0, 9, 4

С станет единицей

Следующий раз с однеркой:

1, 7, 6, 8, 5, 3, 2, 0, 9, 4

И с стало двойкой

И последний раз это случится с нулем, после чего массив будет такой:0, 7, 6, 8, 5, 3, 2, 1, 9, 4

И с станет тройкой.

Надеюсь стало понятнее

0,0(0 оценок)
Ответ:
shopsms982
shopsms982
16.05.2023 04:48

Program Planet;

var
R1, R2, l1, l2, v1, v2, time1, time2 : real;
c, b : string;

begin
Write('Планета1-');
Readln(b);
Write('Планета2-');
Readln(c);
Write('R1=');
Readln(R1);
Write('R2=');
Readln(R2);
Write('v1=');
Readln(v1);
Write('v2=');
Readln(v2);
L1:=2*Pi*R1;
L2:=2*Pi*R2;
Time1:=l1/v1;
Time2:=l2/v2;
Writeln('Продолжительность года на пленете ',b,'= ', Time1:0:2, ' суток');
Writeln('Продолжительность года на пленете ',c,'= ', Time2:0:2, ' суток');
end.

 

 

 

 

как-то так)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота