В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Таисия281
Таисия281
04.12.2021 17:15 •  Информатика

Суммарный индекс паскал имя входного файла: стандартный ввод имя выходного файла: стандартный вывод ограничение по времени: 1 секунда ограничение по памяти: 256 мегабайт в параллельной вселенной винни — не просто медведь, а медведь-айтишник. летом он выбрал жертву, которая не может программировать, и дал ей возможность получить сообщение с готовым программным кодом от случайного человека из другой вселенной. этот человек — вы! для того, чтобы ему , вам нужно вывести элемент массива a на позиции, равной сумме позиций минимального и максимального элемента массива. ему. формат входных данных в первой строке вводится n (1 ⩽ n ⩽ 50) — количество чисел в массиве a. во второй строке вводится n чисел ai (0 ⩽ ai ⩽ 50) — элементы массива a. если максимальных или минимальных значений несколько, используйте первый из них. формат выходных данных выведите искомый элемент или строку «vne massiva», если искомый индекс выходит за границы массива. примеры стандартный ввод стандартный вывод 5 1 5 2 4 3 2 3 1 2 3 vne massiva 1 5 vne massiva

Показать ответ
Ответ:
LianaIlyasova
LianaIlyasova
13.08.2020 02:05
Задача 7. ВОДОЛАЗКА
Задача 2. после 6 применений 64 четных цифры (после каждого применения их количество увеличивается в 2 раза)
Задача 1. не может быть Даша второй, т.к. это утверждение в 4 и 5 строках. Не может быть третьей Ира (предполагается в 3 и 5 строках). Значит первая Маша. А Даша и Ира - не призеры. Из 4-й строки получаем. что и Боря не призер. Из 1 и 3 строки получаем, что Вася - не призер (т.к. указано что Вася второй и Вася третий). Значит призер Таня (не первая и не третья, значит - вторая). Из 2 строки получаем, что и Гена не призер. Остается Антон - третий
ответ: Маша, Таня, Антон
Задача 3. Всего можно составить  60 трехзначных чисел. Числе. меньших 200, 12. Вероятность 12/60=0,2
Задача 9. 16
Задача 4. Можно (Земля-Марс-юпитер-Венера-Меркурий)
Задача 6.
370
343
640
613
910
901
271
253
550
 
0,0(0 оценок)
Ответ:
arsenijakula
arsenijakula
07.02.2020 06:59
//PascalABC.Net 3.0, сборка 1064
var
  n:integer;
  i,d:byte;
  b:array[0..9] of boolean;
  fail:boolean;
begin
  Write('Введите четырехзначное натуральное число: ');
  Read(n);
  for i:=0 to 9 do b[i]:=False;
  while (n>0) and (not fail) do begin
    d:=n mod 10;
    if b[d] then fail:=True else b[d]:=True;
    n:=n div 10
  end;
  if fail then Writeln('В числе есть одинаковые цифры')
  else Writeln('В числе нет одинаковых цифр')
end.

Тестовое решение:
Введите четырехзначное натуральное число: 1263
В числе нет одинаковых цифр

Введите четырехзначное натуральное число: 1315
В числе есть одинаковые цифры
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота