В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
artik12042003
artik12042003
20.02.2023 20:00 •  Информатика

Тема называется ''нахождение экстремальных элементов в одномерных массивах''
звучит так - ''составить программу нахождения заданного экстремального элемента или его порядкового номера при заданном одномерном массиве а из n элементов (или массивах а и с по n элементов в каждом)
не забывать, сформулированы для i=1,. делайте
корректировку согласно принятой в языке индексации при
написании программ.
так звучит для всех и идут индивидуальные, они-то мне и нужны-''определить наименьшее из значений ((2 / а i ) +(a i ^2))''
язык программирования python буду за пояснение, что да как, и признательна за написание кода : з

Показать ответ
Ответ:
TkAl06
TkAl06
26.11.2021 13:37
PascalABC.NET 3.3.5, сборка 1669 от 21.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходная матрица ***');
  var a:=MatrRandom(5,5,-9,9);
  a.Println(3); Writeln(15*'-');
  var s:=a.ElementsByRow.GroupBy(t->t).Select(t->(t.Key,t.Count))
      .Where(t->t[1]>1).OrderBy(t->t[0]);
  var c:=a.ElementsWithIndexes.OrderBy(t->t[0]).ToArray;
  Writeln('Знач. Кол-во Индексы');
  foreach var p in s do begin
    Write(p[0]:3,p[1]:7,'   ');
    var q:=p[0];
    var s1:=c.IndexesOf(t->t[0]=q);
    foreach var k in s1 do
      Write('(',c[k][1]+1,',',c[k][2]+1,') ');
    Writeln
    end
end.
[100б]в матрице 5x5 определить количество и номера однозначных элементов - pascalabc
0,0(0 оценок)
Ответ:
Myziki
Myziki
13.06.2022 15:39

1. Информацию, не зависящую от личного мнения или суждения, называют:

объективной

2. Информацию, отражающую истинное положение вещей, называют:

достоверной

3. Информацию, изложенную на доступном для получателя языке называют:

понятной

4. Информацию, существенную и важную в настоящий момент, называют:

актуальной

5. Наибольший объем информации человек получает при

органов зрения

6. Тактильную информацию человек получает посредством:

органов осязания

7. Во внутренней памяти компьютера представление информации

 дискретно  

8. Перевод текста с английского языка на русский можно назвать

процесс обработки информации  (содержание не меняется, меняется только форма)

9. Обмен информацией — это:

разговор по телефону

10. Основное отличие формальных языков от естественных:

в наличии строгих правил грамматики и синтаксиса  (все остальные варианты вообще неверны: слова могут иметь разное значение в разных контекстах, а количество символов может быть неограниченно большим. Например, символом могут быть натуральные числа, их бесконечно много)

11. В какой из последовательностей единицы измерения указаны в порядке возрастания

байт, килобайт, мегабайт, гигабайт  (1 килобайт = 1024 байт, 1 мегабайт = 1024 килобайт, 1 гигабайт = 1024 мегабайт)

12. Устройством ввода текстовой информации является:

клавиатура

13. Устройством для вывода текстовой информации является:

экран дисплея

14. Какое устройство предназначено для обработки информации?

 Процессор

15. Где расположены основные детали компьютера, отвечающие за его быстродействие?

В системном блоке

16. Для чего предназначена оперативная память компьютера?

Для временного хранения информации

17. Какое устройство предназначено для передачи информации?

Модем

18. Какие из устройств предназначены для ввода информации?

 Сканер

Клавиатура

19. Какие из устройств предназначены для вывода информации?

Принтер

Монитор

20. Какое из устройств компьютера не относится к основным?

Принтер

21. Файл это:

 программа или данные, имеющие имя и хранящиеся в долговременной памяти

22. Имя файла состоит из двух частей:

имени и расширения  (расширение подсказывает, как открыть/запустить файл, но по большому счету в современных файловых системах оно не обрабатывается специальным образом и может быть опущено)

23. Имя файлу даёт:

 *программа при его создании  (этот ответ не будет считаться правильным в тесте, но ничего не мешает программе сгенерировать имя файла без участия пользователя)

пользователь

24. Расширение файлу присваивает:

программа при его создании

*пользователь  (аналогично, пользователь может поменять расширение)

25. Под расширение отводится

3 символа  (привет, вопрос из В современных файловых расширение практически не ограничено в длине)

26. Для того, чтобы на диске можно было хранить файлы, диск должен быть предварительно:

отформатирован

27. Выберите правильное имя файла

12345.BMP

*SPRAVKI (если вы живете в в котором у каждого файла есть расширение длиной не больше 3 символов, то этот ответ неверный. Современные ОС, ФС позволяют опускать расширение. Остальные ответы неверны в ОС Windows и MS-DOS, поскольку в ней не разрешается добавлять : в имя файла)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота