Тема:Одномерные массивы
Дан список 10 магазинов и соответствующий ему список цен на учебники.
Отсортировать список магазинов по возрастанию цен.
Вывести на экран отсортированный список.
Подсчитать и вывести на экран количество магазинов с самыми дешевыми учебниками.
Вывести на экран названия магазинов, где учебники дешевле всего.
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
namespace ConsoleApplication1
{
class Program
{
static void Main(string[] args)
{
//Напишите программу,которая в последовательности целых чисел определяет количество чисел,кратных 5 или 9.
//Программа получает на вход целые числа,количество введённых чисел неизвестно,последовательность чисел заканчивается числом 0.
//Количество чисел не превышает 1000.Введённые числа по модулю не превышают 30 000.Программа должна вывести одно число:количество чисел,кратных 5 или 9.
int n = 0; // количество
int a = int.Parse(Console.ReadLine());
while (a != 0)
{
if (a % 5 == 0 || a % 9 == 0)
n++;
a = int.Parse(Console.ReadLine());
}
Console.WriteLine(n);
Console.ReadKey();
}
}
}
using namespace std;
int Max(int a, int b)
{
if (a>b) return a;
else return b;
}
int Min(int a, int b)
{
if (a<b) return a;
else return b;
}
char F(int a, int b)
{
if (a<b) return '<';
else if (a>b) return '>';
else return '=';
}
int main()
{
int x, y;
cout << "x = ";
cin >> x;
cout << "y = ";
cin >> y;
cout << "Max = " << Max(x,y) << "\n";
cout << "Min = " << Min(x,y) << "\n";
cout << x << F(x,y) << y << "\n";
system("Pause");
return 0;
}
Пример:
x = 15
y = 29
Max = 29
Min = 15
15<29