Требовалось написать программу, которая получает на входе натуральное число n и выводит число, которое получается из n после удаления всех пятерок, порядок остальных цифр при этом не меняется. программист торопился и написал программу неверно, найдите неверную строку и исправьте ее. var n, r, t: longint; d: integer; begin readln (n); r: =0; t: =1; while n> 0 do begin d: =n mod 10; if d=5 then begin r: =r+d*t; t: =t+1 end; n: =n div 10; end; writeln (t); end.
d:integer;
begin
readln (n);
r:=0; t:=1;
while n>0 do begin
d:=n mod 10; if d=5 then begin 1 ошибка: надо вместо d=5 написать d<>5
r:=r+d*t;
t:=t+1 2 ошибка: надо вместо t+1 написать t*10
end;
n:=n div 10;
end;
writeln (t); 3 ошибка: надо вместо t написать r
end.