В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Требуется отсортировать массив по неубыванию методом "пузырька". в первой строке вводится одно натуральное число, не превосходящее 1000 – размер массива. во второй строке nчисел – элементы массива (целые числа, не превосходящие по модулю 1000). на с++ !

Показать ответ
Ответ:
Kamilla1472
Kamilla1472
05.07.2020 09:54
A:array[1..1000] of integer;
i, k, z, n, j:integer;
begin
readln(n);
for i:=1 to n do
readln(a[i]);
for i:=1 to n-1 do
for j:=1 to n-i do
if a[j]>a[j+1] then begin
z:=a[j]; a[j]:=a[j+1]; a[j+1]:=z; end;
for i:=1 to n do
writeln(a[i]);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота