В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
DianaSmile111
DianaSmile111
26.10.2020 02:05 •  Информатика

Три прямые заданы в виде уравнений вида ax + b y +c = 0. Написать программу, проверяющую, образуют ли они треугольник. (Определить функцию, проверяющую, пересекаются ли две прямые ровно в одной точке.)
Случай, когда три прямые пересекаются в одной точке отдельно рассматривать не требуется(c#)

Показать ответ
Ответ:
severina3
severina3
22.10.2022 21:14

Відповідь:

Адресация — осуществление ссылки (обращение) к устройству или элементу данных по его адресу; установление соответствия между множеством однотипных объектов и множеством их адресов; метод идентификации местоположения объекта. Простая (англ. flat addressing) — указание объекта с идентификатора или числа, не имеющего внутренней структуры. Расширенная (англ. extended addressing) — доступ к запоминающему устройству с адресным пространством, бо́льшим диапазоном адресов, предусмотренного форматом

Пояснення:

0,0(0 оценок)
Ответ:
Yulia14929
Yulia14929
23.01.2022 04:45

bd = {} #База данных будет организована в виде словаря

while 1:

   name = input("Введите имя пассажира: ")         #Имя - ключ к весу и количеству вещей

   kol_vo = int(input("Введите кол-во вещей: "))   #Не требует объяснения

   ves = float(input("Введите вес багажа: "))

   bd[name]={'kol-vo':kol_vo, 'ves':ves}           #По имени получаем дальнейшую информацию

   srednee=0                                       #Сбрасываем среднее арифметическое

   for passazir in bd:                             #Переберём пассажиров

       srednee+=bd[passazir]['kol-vo']             #Сложим кол-во их вещей

   srednee/=len(bd)                                #И разделим на кол-во пассажиров

   for passazir in bd:                             #Переберём пассажиров

       if bd[passazir]['kol-vo'] > srednee:        #Если у пассажира больше среднего

           print("У пассажира %s вещей больше среднего!" % passazir) #Песатаем его имя

   if input("Завершить [y/n]? ").lower() == 'y':                     #Проверяем, выйти ли из цикла

       break

#.lower() - переводит строку в нижний регистр

#" text %s text" % переменная - подставляет переменную в текст ( аналогично " text " + переменная + " text")

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота