У вас есть персонаж, обладающий рядом и статов.
Напишите программу по заданным условиям:
1. Персонаж имеет набор статов: strength, dexterity,
intelligence, wisdom, charisma. Каждая стата имеет свой
запас.
1
Домашнее задание № 9
Значения запасов каждой статы должны быть случайны
– в пределах от 60 до 80 и быть представлены в списке
stats = []:
stats = []
for i in range(5):
r = random.randint(60, 80)
stats.append(r)
2. В начале игры пользователю предоставляется
возможность однократно повысить одну стату на
случайное количество единиц – от 5 до 15:
select = int(input('Select: '))
select -= 1
stats[select] += random.randint(5, 15)
Обратите внимание, что повышая одну стату на
сгенерированное число, все остальные должны
уменьшиться на случайное значение в пределах от 5 до 15:
for i in range(len(stats)):
if i == select:
continue
stats[i] -= random.randint(5, 15)
2
Домашнее задание № 9
3. Персонаж обладает набором скилов: fireball, lightning,
silence, fire ward.
Использование каждого из них отнимает разное
количество единиц статов, а именно:
Атрибуты
Fireball 12 15 28 10 5
Lightning 7 13 15 30 10
Silence 23 10 12 7 18
Fire Ward 20 23 14 6 17
Занесите эти данные в список, чтобы в
дальнейшем воспользоваться ими в игре:
fireball = [12, 15, 28, 10, 5]
lightning = [7, 13, 15, 30, 10]
...
3
Домашнее задание № 9
4. Предоставьте пользователю возможность использовать
скилы, например, по нажатию f применяется Fireball,
l – Lightning и т. д. После применения какой-либо
из запас статов будет уменьшаться,
согласно приведенной выше таблице.
Рассмотрим следующий пример:
1. Было Stats: 70 64 63 80 65.
2. Применили Fireball: 12 15 28 10 5.
3. Стало Stats: 58 49 35 70 60.
Следите за тем, чтобы элементы в списке
stats=[] не стали отрицательными.
Спутники Урана — естественные спутники планеты Уран. Известно 27 спутников. Все они получили названия в честь персонажей из произведений Уильяма Шекспира и Александра Поупа. Первые два спутника — Титанию и Оберон — в 1787 году открылУильям Гершель. Ещё два сферических спутника (Ариэль и Умбриэль) были открыты в 1851 году Уильямом Ласселом. В 1948 году Джерард Койпер открыл Миранду. Остальные спутники были открыты после 1985 года, во время миссии «Вояджера-2», или с усовершенствованных наземных телескопов.
вот программа на языке PASCALABC
uses crt;
const max=20;
var a:array [1..max,1..max] of byte;
n,i,j,k,s,s1,s2,s3:integer;
x:char;
begin
x:=x;
repeat
Writeln('vvedite kol-vo komand N');
Readln(N);
until N in [1..max];
for i:=1 to N do
for j:=1 to N do
A[i,j]:=random(3);
For i:=1 to N do
begin
for j:=1 to N do
if i=j then write(#204:4)
else Write(a[i,j]:4);
writeln;
end;
writeln('íîìåðà êîìàíä, èìåþùèõ áîëüøå ïîáåä íà ÷óæîì ïîëå');
k:=0;
s:=0;
s3:=0;
for i:=1 to n do
begin
for j:=1 to n do
begin
if a[i,j]=2 then s1:=s+1;
if a[j,i]=0 then s2:=s3+1;
s:=s1;
s3:=s2;
end;
end;
if s2>s1 then
begin
writeln('Nomer komandy - ',i,' Kol. pobed = ',s2);
k:=1
end;
if k=0 then writeln('takih komand net');
end.