В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
alinkaaa25
alinkaaa25
17.02.2021 21:00 •  Информатика

Вам дано число  x. найдите все его простые делители.python

Показать ответ
Ответ:
оаоашвов
оаоашвов
28.08.2021 17:18

Если имеется в виду (a*b);

то будет 48

Тоесть такой код:

a=4; b=2; c=6

a=(a*b)*c

print(a)

Ну а если так:

Ну а если так:Выйдет ошибка:

Traceback (most recent call last):

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module>

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile)

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__)

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__) File "<string>", line 2, in <module>

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__) File "<string>", line 2, in <module>NameError: name 'ab' is not defined

0,0(0 оценок)
Ответ:
КрохаДи
КрохаДи
20.05.2023 05:52

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()


Напишите программу на python которая генерирует случайный пример на сложение двух чисел, например
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота