Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Ckorpid
01.06.2022 07:34 •
Информатика
Вести n чисел и найти среднее арифметическое. написать программу и нарисовать блок схему.
Показать ответ
Ответ:
tvoibati00
18.09.2020 13:58
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL,"Rus");
int N,dp,S,F,d;
S=0;F=0;d=0;
while(S<1){
cout<<"Выберите действие"<<endl;
cout<<"1.Ввод чисел"<<endl;
cout<<"2.Подсчет среднего арифметического"<<endl;
cout<<"Выполнить действие-";
cin>>dp;
switch(dp){
case 1:
cout<<"Введите число ";
cin>>N;
F=F+N;
d++;
break;
case 2:
S=(float)F/d;
break;
}
}
cout<<"Среднее арифметическое="<<S<<endl; system("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Алиса547828
31.07.2020 17:10
Напишіть програму, в якій викликається функція, яка запитує у користувача два слова і повертає (через return) в програму результат їх конкатенації (об єднання тобто +). Виведіть результат...
nataliarianna29
09.06.2022 03:39
Нарисуйте блок схему и напише программу для подсчёта сумму и произведения чисел вводимого числа. ...
asli121
22.07.2021 22:58
Припишите справа к данному числу число, составленное из тех же цифр, и данное. 1) 732 = 2) 2591 = 3) 67840 =...
tatulia32
30.04.2023 11:20
Собственная скорость яхты 20 км/ч, а скорость течения реки в 6 2/3 раза меньше. яхта и плот отправились от пристани вниз по течению,причем яхта начала дыижение на 2 2/3 часа раньше....
ДашаКотик2007
30.04.2023 11:20
Составьте предложения с complex object, используя глагол, данный в скобках. i think she will phone. (expect) my father said i could use his car. (allow) i suggested that she should...
Alice547
30.04.2023 11:20
Напишите следующие глаголы в 3 лице единственного числа ( he, she, it) drive, speak, draw, play, have, help....
Madik1111111
30.04.2023 11:20
There is apple on the plate. apple is red will you go to the laboratory ( после ) lessons? why don’t you trust ? i said i would do it and i will i can’t see it’s too dark here did...
1234567890love
30.04.2023 11:20
Полый цинковый шар плавает в керосине, погрузившись в него на 45 % своего объёма. определите, какую часть объёма шара занимает полость. плотность керосина 800 кг/м³; плотность цинка...
kidsers2017Milllooo
30.04.2023 11:20
Ilooked my keys but i couldn’t find them anywhere. (preposition) we spend free time together i don’t like he is rude and loud. his friends in almaty two weeks ago (to be) farida at...
КРИЛЛ2000
28.12.2021 06:11
Все ниже признаки, кроме двух, характеризуют искусственный отбор. определите два признака, «» из общего списка, и запишите в таблицу цифры, под которыми они указаны 1) отбирающий фактор...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main(){
setlocale(LC_ALL,"Rus");
int N,dp,S,F,d;
S=0;F=0;d=0;
while(S<1){
cout<<"Выберите действие"<<endl;
cout<<"1.Ввод чисел"<<endl;
cout<<"2.Подсчет среднего арифметического"<<endl;
cout<<"Выполнить действие-";
cin>>dp;
switch(dp){
case 1:
cout<<"Введите число ";
cin>>N;
F=F+N;
d++;
break;
case 2:
S=(float)F/d;
break;
}
}
cout<<"Среднее арифметическое="<<S<<endl; system("pause");
return 0;
}