Насмотревшись Гривити Фолз и вдохновившись всякими загадками, которыми этот сериал был напичкан, я полез искать информацию про всякие шифры. И тут меня посетила идея сделать на основе шифров квест для своей жены (тогда ещё девушки). У меня в наличии было 2 дня, т.к. она уехала в гости к маме и мне не пришлось шифроваться. Бегло накидав на листик план действий, я полез за материалом. Шифров, загадок, ребусов в интернете оказалось очень много. Почти 2 дня у меня и ушло вперемешку с сериальчиков, листания пикабу и пинанием хрена.
Сейчас покажу всё, что в итоге получилось из моей затеи.
В задании не сказано, откуда берутся исходные данные, поэтому будем вводить их с клавиатуры. Сначала ведем общее количество данных (не факт, что данные за месяц снимались строго ежедневно), а затем сами данные. Это позволит заодно осуществить контроль ввода.
var n,s,t,i:integer; begin Write('Укажите количество данных: '); Read(n); Writeln('Теперь вводите данные'); s:=0; for i:=1 to n do begin Read(t); s:=s+t end; Writeln('Средняя температура за месяц составила ',s/n:0:1) end.
Пример решения
Укажите количество данных: 11 Теперь вводите данные 27 29 26 31 24 23 27 30 31 28 25 Средняя температура за месяц составила 27.4
Привет Пикабу!
Насмотревшись Гривити Фолз и вдохновившись всякими загадками, которыми этот сериал был напичкан, я полез искать информацию про всякие шифры. И тут меня посетила идея сделать на основе шифров квест для своей жены (тогда ещё девушки). У меня в наличии было 2 дня, т.к. она уехала в гости к маме и мне не пришлось шифроваться. Бегло накидав на листик план действий, я полез за материалом. Шифров, загадок, ребусов в интернете оказалось очень много. Почти 2 дня у меня и ушло вперемешку с сериальчиков, листания пикабу и пинанием хрена.
Сейчас покажу всё, что в итоге получилось из моей затеи.
Объяснение:
var
n,s,t,i:integer;
begin
Write('Укажите количество данных: ');
Read(n);
Writeln('Теперь вводите данные');
s:=0;
for i:=1 to n do
begin
Read(t);
s:=s+t
end;
Writeln('Средняя температура за месяц составила ',s/n:0:1)
end.
Пример решения
Укажите количество данных: 11
Теперь вводите данные
27 29 26 31 24 23 27 30 31 28 25
Средняя температура за месяц составила 27.4