В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
TamiDobro
TamiDobro
12.12.2021 11:40 •  Информатика

Язык Си. Составить программу, которая позволяет найти произведение нечетных цифр трехзначного числа.

Показать ответ
Ответ:
Sane1999
Sane1999
01.03.2023 10:17

только в сети с полносвязной топологией для соединения каждой пары компьютеров имеется отдельная линия связи. во всех остальных случаях возникает вопрос о том, как организовать совместное использование линий связи несколькими компьютерами.

в вычислительных сетях используют как индивидуальные линии связи между компьютерами, так и разделяемые, когда одна линия связи попеременно используется несколькими компьютерами.

существуют различные технологии организации сети:

ethernet – (эзернет) – это наиболее популярная сетевая технология, используемая для создания локальных сетей. основной принцип, положенный в основу – случайный метод доступа к разделяемой среде передачи данных. в качестве такой среды может использоваться коаксиальный кабель, витая пара, оптоволокно или радиоволны. топология электрических связей –общая шина.

суть метода случайного доступа в следующем – информацию компьютер вначале убеждается, что сеть свободна, потом передает информацию. ее принимают все другие компьютеры. если информация предназначена им (они анализируют адрес назначения), то они ее копируют.

главное достоинство сети ethernet – – достаточно иметь сетевые адаптеры на компьютерах и кусок коаксиального кабеля.

token ring – кольцевая сеть, каждый узел кольца ожидает прибытие пакета информации адресованного ему.

однако в последние годы наметилась тенденция отказа от разделяемых сред передачи данных. это связано с низкой производительностью таких сетей. компьютеры подключаются индивидуальными линиями связи к специальному устройству - коммутатору. следует подчеркнуть, что связи между компьютерами остаются разделяемыми.

в сетях отказ от разделяемых линий связи объясняется техническими причинами: компьютеры могут затратить больше времени на переговоры о том, кому сейчас можно использовать линии связи, чем непосредственно на передачу данных по линии связи.

0,0(0 оценок)
Ответ:
Xiyneu
Xiyneu
23.12.2021 10:18

ответ:

uses crt;

var a: array[1..20,1..20] of real;

    n,m,i,j: integer;

    s: real;

begin

    clrscr; randomize;

    write('введите кол-во строк: '); readln(n);

    write('введите кол-во столбцов: '); readln(m);

    for i: =1 to n do

    begin

      for j: =1 to m do

      begin

        a[i,j]: =random(100)/10;

        write(a[i,j]: 4: 1);

      end;

      writeln;

    end;

    for i: =1 to n do

    begin

      s: =0;

      for j: =1 to m do

      s: =s+a[i,j];

      writeln('сумма ',i,'-ой строки: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      for i: =1 to n do

      s: =s+a[i,j];

      writeln('сумма ',j,'-ого столбца: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      if j mod 2 = 0 then  

      begin

        for i: =1 to n do

        s: =s+a[i,j];

        writeln('среднее арифметическое ',j,'-ого столбца: ',s/m: 0: 1);

      end;

    end;

    readln;

end.

объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота