В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Задача №6 на пайтоне
Напишите программу, которая запрашивает двузначные числа A и B (A<=B) и определяет, есть ли в диапазоне чисел от A до B включительно такие, что сумма цифр равна 10. Если таких чисел нет - выведите "NO", а если есть выведите - "YES".

Sample Input 1:

10 18
Sample Output 1:

NO
Sample Input 2:

10 20
Sample Output 2:

YES

Показать ответ
Ответ:
mrflotov
mrflotov
13.04.2021 20:59

a = int(input('Введите a: '))

while True:

 b = int(input('Введите b (b>a): '))

 if b>a: break

 print('b должно быть больше a!')

check = False

for i in range(a,b+1):

 j = i

 s = 0

 while j > 0:

   s += j%10

   j = j//10

 if s == 10:

   check = True

   break

print('YES' if check else 'NO')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота