В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Leprekon11
Leprekon11
21.12.2021 04:27 •  Информатика

Задача No4 Составьте программу вычисления у по заданному х.
— 3х, х<0
y=
х+5, x 2 0
Пример входных данных
х=-5
х=2
Пример выходных данных
y=15
y=7​

Показать ответ
Ответ:
mariyasidorova1
mariyasidorova1
07.11.2022 15:15

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
0,0(0 оценок)
Ответ:
tsagol10
tsagol10
28.10.2020 14:00

Відповідь:

ассмотрим, что происходит в результате поворота точки. Пусть некоторая точка  

А

поворачивается относительно центра поворота  

О

, в результате чего получается точка  

А

1

(при совершении некоторого количества полных оборотов она может совпасть с точкой  

А

). При этом точка  

А

1

лежит на окружности с центром в точке  

О

радиуса  

О

А

. Другими словами, когда точка  

А

осуществляет поворот относительно точки  

О

, она переходит в точку  

А

1

, лежащую на окружности с центром  

О

радиуса  

О

А

.

Пояснення:

ты про ёто?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота