В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
djonli1
djonli1
26.12.2022 13:06 •  Информатика

Задачи «В»: Напишите программу, которая заполняет матрицу
случайными числами и находит максимальный
элемент матрицы и его индексы (номера строки и
столбца).
Пример:
Матрица А:
12 34 14 65
71 88 23 98
87 46 53 39
76 58 24 92
Максимум: A[2, 4] = 98


Задачи «В»: Напишите программу, которая заполняет матрицуслучайными числами и находит максимальныйэл

Показать ответ
Ответ:
анна2259
анна2259
30.03.2021 12:19

import random

a = [0] * 4  

for i in range(4):  

   a[i] = [0] * 4

mi = 1

mj = 1

print("Матрица A:")

for i in range (4):

   for j in range (4):

       a[i][j] = random.randint(10,99)

       if a[i][j]>a[mi][mj]:

           mi = i

           mj = j

       print("%3d" % (a[i][j]),end="")

   print()

print("Максимум: A[{0},{1}] = {2}".format(mi+1,mj+1,a[mi][mj]))

Объяснение:

Создаём матрицу заполненную 0

Задаём начальные значения максимальных индексов

Заполняем матрицу случайными числами, ищем максимальные индексы и выводим элементы на экран

Выводим максимальные индексы и значение элемента


Задачи «В»: Напишите программу, которая заполняет матрицуслучайными числами и находит максимальныйэл
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота