В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
bahyt061089
bahyt061089
25.08.2022 13:32 •  Информатика

Задан числовой массив, состоящий из 9 элементов. найти и вывести на экран произведение всех элементов, меньших максимального.надо составить программу.,

Показать ответ
Ответ:
alskyuq
alskyuq
21.07.2020 11:54
Program programma;
uses crt;
var
a:array[1..100]of integer;
i,max,p:integer;
begin
clrscr;

p:=1;
for i:=1 to 9 do
begin
write('a[',i,'] = ');
readln(a[i]);
end;

for i:=1 to 9 do
begin
if a[i]> max then max:=a[i];
end;

for i:=1 to 9 do
begin
if a[i]<> max then
p:=p* a[i]
end;
writeln;
writeln('max = ', max);
write('P = ',p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота