В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kazakov1206
kazakov1206
23.10.2020 00:32 •  Информатика

Задан двумерный массив m на n. составить программу которая организует одномерный массив, каждый элемент которого есть произведение элементов массива а в каждой строке. pascal. !

Показать ответ
Ответ:
katysha087
katysha087
12.03.2023 11:16
1.

program xopow1;
   uses   crt;
   var  
 a, b, Sek: integer;  
begin  
writeln('Введите границы:');  
repeat    
readln(a, b);  
until b >= a;  
 clrscr;  
for a := a to b do
    begin    
Sek := a * 60;    
writeln(a, ' мин. = ', sek, ' сек.')  
end
end.

2.

program xopow2;
  uses crt; 
Var
 z:integer;
 f,x,y:real; 
Begin 
clrscr; 
Writeln;
X:=10000;
Y:=(x/100)*10;
for z:=1 to 7 do 
 Begin 
X:=x+y; 
Writeln(Z,' -й день тренировок спортсмен пробежал ',X:3:2,' Км.'); 
End; 
Writeln('Нажмите Enter...'); 
Readln; 
end.
0,0(0 оценок)
Ответ:
stepnikitka
stepnikitka
17.08.2021 02:57
PROGRAM PR21;
var // блок описания переменных
S: real; 
I, N, J, K, L, M: Integer;
begin
S:=-l; // задаем начальное значение переменной, в которой будет хранится ответ. -1 потому что программа посчитает билет с номером 000000
for I := 0 to 9 // перебор первой цифры
do for J:=0 to 9 // перебор второй цифры
do for K:=0 to 9 // третьей
do for L:=0 to 9 // четвертой 
do for M:=0 to 9 // пятой
do for N:=0 to 9 // шестой
do 
if I+J + K = L+M + N // проверяем равны ли суммы первых трех и последних трех цифр
thenS:=S+ 1; // если равны, то прибавим билет к ответу
writeln('Число счастливых билетов = ', S:6:0); // выводим ответ, отведя 6 позиций для числа
readln; // нужно, чтобы не закрылось диалоговое окно (хотя в некоторых средах можно обойтись без этого)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота